Sets the indicated end of the framing element to be allowed to join to others.
Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- familyInstance
-
Type:
Autodesk.Revit.DB
FamilyInstance
The FamilyInstance, which must be of a structural framing category.
- end
-
Type:
System
Int32
The index of the end (0 for the start, 1 for the end).
Remarks
If that end is near other elements it will become joined as a result.
By default all framing elements are allowed to join at ends, so this function is only needed if this element end is already disallowed to join.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | end must be 0 or 1. |
Autodesk.Revit.Exceptions ArgumentsInconsistentException | The input familyInstance is not of a structural framing category. |