Creates a filled region from the given boundaries.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The document in which to create the filled region.
- typeId
- Type: Autodesk.Revit.DB ElementId
The filled region type Id.
- viewId
- Type: Autodesk.Revit.DB ElementId
The view Id.
- boundaries
- Type: System.Collections.Generic IList CurveLoop
The boundaries.
Return Value
The newly created filled region.Remarks
The line style of the boundaries will be set to thin lines by default.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The Id typeId is invalid. -or- Thrown if the viewId or typeId is invalid, or the view does not support the detail items creation, or if the boundaries are empty, open, or self-intersecting. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |