Combine a set of combinable elements into a geometry combination.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- members
-
Type:
Autodesk.Revit.DB
CombinableElementArray
A list of combinable elements to be combined.
Return Value
If successful, the newly created geometry combination is returned, otherwise an exception with error information will be thrown.Remarks
If one or more existing geometry combinations are included as input, the return value may be one of those pre-existing
combinations. The rest of the pre-existing geometry combinations will be consumed into the new combination; those handles are no longer valid.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the input argument is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown when members contains less than two elements. Thrown when members contains a null reference ( Nothing in Visual Basic) elements. |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when creation of the combination failed. |