Posts the command to the Revit message queue to be invoked when control returns from the current API context.
Namespace:
Autodesk.Revit.UI
Assembly:
RevitAPIUI
(in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- commandId
-
Type:
Autodesk.Revit.UI
RevitCommandId
The command Id.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when commandId is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | If the command cannot be posted. |
Autodesk.Revit.Exceptions InvalidOperationException | If there is a command already been posted. |