Sets the extents to match the curve.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since:
2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- extentMode
-
Type:
Autodesk.Revit.DB
DatumExtentType
The extent type.
- view
-
Type:
Autodesk.Revit.DB
View
The view.
- curve
-
Type:
Autodesk.Revit.DB
Curve
The curve.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The datum plane cannot be visible in the view. -or- The curve is unbound or not coincident with the original one of the datum plane. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |