Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since:
2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
The input solid used for this filter can be obtained from an existing element, created from scratch using the routines in GeometryCreationUtilities or builder classes, or the generated from the result of a secondary operation such as a Boolean operation. Similar to the ElementIntersectsElementFilter , this filter will not detect as intersecting elements which lack solid geometry, such as Rebar.
This filter is a slow filter. Slow filters require that the Element be obtained and expanded in memory first. Thus it is preferable to couple this filter with at least one ElementQuickFilter, which should minimize the number of Elements that are expanded.
Examples
// Find intersections between family instances and a selected element
Reference reference = uidoc.Selection.PickObject(ObjectType.Element, "Select element that will be checked for intersection with all family instances");
Element element = doc.GetElement(reference);
GeometryElement geomElement = element.get_Geometry(new Options());
Solid solid = null;
foreach (GeometryObject geomObj in geomElement)
{
solid = geomObj as Solid;
if (solid != null) break;
}
FilteredElementCollector collector = new FilteredElementCollector(doc);
collector.OfClass(typeof(FamilyInstance));
collector.WherePasses(new ElementIntersectsSolidFilter(solid)); // Apply intersection filter to find matches
TaskDialog.Show("Revit", collector.Count() + " family instances intersect with the selected element (" + element.Category.Name + " id:" + element.Id.ToString() + ")");
// Find intersections between family instances and a selected element
Reference reference = uidoc.Selection.PickObject(ObjectType.Element, "Select element that will be checked for intersection with all family instances");
Element element = doc.GetElement(reference);
GeometryElement geomElement = element.get_Geometry(new Options());
Solid solid = null;
foreach (GeometryObject geomObj in geomElement)
{
solid = geomObj as Solid;
if (solid != null) break;
}
FilteredElementCollector collector = new FilteredElementCollector(doc);
collector.OfClass(typeof(FamilyInstance));
collector.WherePasses(new ElementIntersectsSolidFilter(solid)); // Apply intersection filter to find matches
TaskDialog.Show("Revit", collector.Count() + " family instances intersect with the selected element (" + element.Category.Name + " id:" + element.Id.ToString() + ")");
' Find intersections between family instances and a selected element
Dim reference As Reference = uidoc.Selection.PickObject(ObjectType.Element, "Select element that will be checked for intersection with all family instances")
Dim element As Element = doc.GetElement(reference)
Dim geomElement As GeometryElement = element.Geometry(New Options())
Dim solid As Solid = Nothing
For Each geomObj As GeometryObject In geomElement
solid = TryCast(geomObj, Solid)
If solid IsNot Nothing Then
Exit For
End If
Next
Dim collector As New FilteredElementCollector(doc)
collector.OfClass(GetType(FamilyInstance))
collector.WherePasses(New ElementIntersectsSolidFilter(solid))
' Apply intersection filter to find matches
TaskDialog.Show("Revit", collector.Count() + " family instances intersect with the selected element (" + element.Category.Name + " id:" + element.Id.ToString() + ")")
' Find intersections between family instances and a selected element
Dim reference As Reference = uidoc.Selection.PickObject(ObjectType.Element, "Select element that will be checked for intersection with all family instances")
Dim element As Element = doc.GetElement(reference)
Dim geomElement As GeometryElement = element.Geometry(New Options())
Dim solid As Solid = Nothing
For Each geomObj As GeometryObject In geomElement
solid = TryCast(geomObj, Solid)
If solid IsNot Nothing Then
Exit For
End If
Next
Dim collector As New FilteredElementCollector(doc)
collector.OfClass(GetType(FamilyInstance))
collector.WherePasses(New ElementIntersectsSolidFilter(solid))
' Apply intersection filter to find matches
TaskDialog.Show("Revit", collector.Count() + " family instances intersect with the selected element (" + element.Category.Name + " id:" + element.Id.ToString() + ")")
Inheritance Hierarchy
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementSlowFilter
Autodesk.Revit.DB ElementIntersectsFilter
Autodesk.Revit.DB ElementIntersectsSolidFilter