Creates a new Solid which is the transformation of the input Solid.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since:
2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- solid
-
Type:
Autodesk.Revit.DB
Solid
The input solid to be transformed.
- transform
-
Type:
Autodesk.Revit.DB
Transform
The transform (which must be conformal).
Return Value
The newly created Solid.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | transform is not conformal. -or- transform has a scale that is negative or zero. |