Creates a new instance of a shape driven Rebar element within the project.
Namespace:
Autodesk.Revit.DB.Structure
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since:
2009
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
-
Type:
Autodesk.Revit.DB
Document
A document.
- style
-
Type:
Autodesk.Revit.DB.Structure
RebarStyle
The usage of the bar, "standard" or "stirrup/tie".
- barType
-
Type:
Autodesk.Revit.DB.Structure
RebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
- startHook
-
Type:
Autodesk.Revit.DB.Structure
RebarHookType
A RebarHookType element that defines the hook for the start of the bar. If this parameter is a null reference ( Nothing in Visual Basic) , it means to create a rebar with no hook.
- endHook
-
Type:
Autodesk.Revit.DB.Structure
RebarHookType
A RebarHookType element that defines the hook for the end of the bar. If this parameter is a null reference ( Nothing in Visual Basic) , it means to create a rebar with no hook.
- host
-
Type:
Autodesk.Revit.DB
Element
The element to which the rebar belongs. The element must support rebar hosting; see Autodesk.Revit.DB.Structure.RebarHostData.
- norm
-
Type:
Autodesk.Revit.DB
XYZ
The normal to the plane that the rebar curves lie on.
- curves
-
Type:
System.Collections.Generic
IList
Curve
An array of curves that define the shape of the rebar curves. They must belong to the plane defined by the normal and origin. Bends and hooks should not be included in the array of curves.
- startHookOrient
-
Type:
Autodesk.Revit.DB.Structure
RebarHookOrientation
Defines the orientation of the hook plane at the start of the rebar with respect to the orientation of the first curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
- endHookOrient
-
Type:
Autodesk.Revit.DB.Structure
RebarHookOrientation
Defines the orientation of the hook plane at the end of the rebar with respect to the orientation of the last curve and the plane normal. Only two values are permitted: Value = Right: The hook is on your right as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up." Value = Left: The hook is on your left as you stand at the end of the bar, with the bar behind you, taking the bar's normal as "up."
- useExistingShapeIfPossible
-
Type:
System
Boolean
Attempts to assign a RebarShape from those existing in the document. If no shape matches, NewRebar returns or creates a new shape, according to the parameter createNewShape. When both parameters are "true", the behavior is the same as sketching rebar in the UI. At least one of these parameters must be "true". If the RebarShapeDefinesHooks flag in ReinforcementSettings has been set to false, and a RebarShape cannot be found with both matching curves and hooks, then this method will perform a second search, ignoring hook information.
- createNewShape
-
Type:
System
Boolean
Creates a shape in the document to match the curves, hooks, and style specified, and assigns it to the new rebar instance. Shape creation will not succeed unless one or more other shapes already exist in the document, and these shapes have enough shape parameters to define a shape for these curves.
Return Value
The newly created Rebar instance, or a null reference ( Nothing in Visual Basic) if the operation fails.Examples
![](https://d24b2zsrnzhmgb.cloudfront.net/static/img/chm/icons/CopyCode.gif)
Rebar CreateRebar(Autodesk.Revit.DB.Document document, FamilyInstance column, RebarBarType barType, RebarHookType hookType)
{
// Define the rebar geometry information - Line rebar
LocationPoint location = column.Location as LocationPoint;
XYZ origin = location.Point;
XYZ normal = new XYZ(1, 0, 0);
// create rebar 9' long
XYZ rebarLineEnd = new XYZ(origin.X, origin.Y, origin.Z + 9);
Line rebarLine = Line.CreateBound(origin, rebarLineEnd);
// Create the line rebar
IList<Curve> curves = new List<Curve>();
curves.Add(rebarLine);
Rebar rebar = Rebar.CreateFromCurves(document, Autodesk.Revit.DB.Structure.RebarStyle.Standard, barType, hookType, hookType,
column, origin, curves, RebarHookOrientation.Right, RebarHookOrientation.Left, true, true);
if (null != rebar)
{
// set specific layout for new rebar as fixed number, with 10 bars, distribution path length of 1.5'
// with bars of the bar set on the same side of the rebar plane as indicated by normal
// and both first and last bar in the set are shown
rebar.GetShapeDrivenAccessor().SetLayoutAsFixedNumber(10, 1.5, true, true, true);
}
return rebar;
}
![](https://d24b2zsrnzhmgb.cloudfront.net/static/img/chm/icons/CopyCode.gif)
Private Function CreateRebar(document As Autodesk.Revit.DB.Document, column As FamilyInstance, barType As RebarBarType, hookType As RebarHookType) As Rebar
' Define the rebar geometry information - Line rebar
Dim location As LocationPoint = TryCast(column.Location, LocationPoint)
Dim origin As XYZ = location.Point
Dim normal As New XYZ(1, 0, 0)
' create rebar 9' long
Dim rebarLineEnd As New XYZ(origin.X, origin.Y, origin.Z + 9)
Dim rebarLine As Line = Line.CreateBound(origin, rebarLineEnd)
' Create the line rebar
Dim curves As IList(Of Curve) = New List(Of Curve)()
curves.Add(rebarLine)
Dim rebar__1 As Rebar = Rebar.CreateFromCurves(document, Autodesk.Revit.DB.[Structure].RebarStyle.Standard, barType, hookType, hookType, column, _
origin, curves, RebarHookOrientation.Right, RebarHookOrientation.Left, True, True)
If rebar__1 IsNot Nothing Then
' set specific layout for new rebar as fixed number, with 10 bars, distribution path length of 1.5'
' with bars of the bar set on the same side of the rebar plane as indicated by normal
' and both first and last bar in the set are shown
rebar__1.GetShapeDrivenAccessor().SetLayoutAsFixedNumber(10, 1.5, True, True, True)
End If
Return rebar__1
End Function
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The element host was not found in the given document. -or- host is not a valid rebar host. -or- The input curves is empty. -or- The input curves contains at least one curve which is not a bound Line or bound Arc and is not supported for this operation. -or- curves do not form a valid CurveLoop. -or- The input curves contains at least one helical curve and is not supported for this operation. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | norm has zero length. -or- A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions ArgumentsInconsistentException | Both useExistingShapeIfPossible and createNewShape are false. -or- curves contains non-fillet arcs with radii that are less than the minimum bend radius for the RebarBarType and bar style. |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |