A stable unique identifier for an element within the document.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
Remarks
The UniqueId can be used to store an identifier in an external database and to retrieve the same element in the future if it still exists.
This id can be passed to the Document's Element property to retrieve the element. The UniqueId is stable across upgrades and workset
operations such as Save To Central, while the
ElementId
property may change.
Examples
Copy
C#
private void CheckElementUniqueId(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
String uniqueId = element.UniqueId;
// Get the element using the UniqueId
Autodesk.Revit.DB.Element elem = document.GetElement(uniqueId);
String prompt = "UniqueId of element is: " + uniqueId;
prompt += "\nUniqueID of elem is: " + elem.UniqueId;
}
Copy
VB.NET
Private Sub CheckElementUniqueId(document As Autodesk.Revit.DB.Document, element As Autodesk.Revit.DB.Element)
Dim uniqueId As [String] = element.UniqueId
' Get the element using the UniqueId
Dim elem As Autodesk.Revit.DB.Element = document.GetElement(uniqueId)
Dim prompt As [String] = "UniqueId of element is: " & uniqueId
prompt += vbLf & "UniqueID of elem is: " + elem.UniqueId
End Sub