Create a MassLevelData (Mass Floor) to associate a Level with a mass instance.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
-
Type:
Autodesk.Revit.DB
Document
The Document.
- massInstanceId
-
Type:
Autodesk.Revit.DB
ElementId
The ElementId of the mass instance.
- levelId
-
Type:
Autodesk.Revit.DB
ElementId
The ElementId of the Level to associate with the mass instance.
Return Value
The ElementId of the MassLevelData that was created, or the existing ElementId if it was already in added.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The ElementId massInstanceId is not a mass instance. -or- The ElementId levelId is not a Level. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |