Exports the document in 3D-Studio Max (FBX) format.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- folder
-
Type:
System
String
Output folder, into which file(s) will be exported. The folder must exist.
- name
-
Type:
System
String
Either the name of a single file or a prefix for a set of files. If a null reference ( Nothing in Visual Basic) or empty, automatic naming will be used.
- views
-
Type:
Autodesk.Revit.DB
ViewSet
Selection of views to be exported.Only 3D views are allowed.
- options
-
Type:
Autodesk.Revit.DB
FBXExportOptions
Options applicable to the FBX format.
Return Value
Function returns true only if all specified views are exported successfully. The function returns False if exporting of any view fails, even if some views might have been exported successfully.Remarks
Though the 'options' argument is not currently used,
an object still must be provided (may be
a null reference (
Nothing
in Visual Basic)
).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the input views is a null reference ( Nothing in Visual Basic) |
Autodesk.Revit.Exceptions ArgumentException | Thrown when the input views is an empty ViewSet. Thrown if any view in the views is not a 3D view. |