Opens and activates a Revit document.
Namespace:
Autodesk.Revit.UI
Assembly:
RevitAPIUI
(in RevitAPIUI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- fileName
-
Type:
System
String
A full path to a revit file to be opened. The file can be either a Revit project, template, or family document.
Remarks
This method, if successful, changes the active document.
It is not allowed to have an open transaction in the active document when calling this method.
Consequently, this method can only be used in manual transaction mode, not in automatic mode.
Additionally, this method may not be called from inside an event handler.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | If a null reference ( Nothing in Visual Basic) is passed as 'fileName'. |
Autodesk.Revit.Exceptions FileArgumentNotFoundException | The file specified by 'fileName' cannot be found. |
Autodesk.Revit.Exceptions ArgumentException | The given 'fileName' is not a Revit file (a project, template, or family document). |
Autodesk.Revit.Exceptions InvalidOperationException |
|