Returns all the stairs run components in the stairs.
Namespace:
Autodesk.Revit.DB.Architecture
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since:
2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
The stairs run components in the stairs.Examples
Copy
C#
private void AddStartandEndRisers(Stairs stairs)
{
ICollection<ElementId> runIds = stairs.GetStairsRuns();
foreach (ElementId runId in runIds)
{
StairsRun run = stairs.Document.GetElement(runId) as StairsRun;
if (null != run)
{
run.BeginsWithRiser = true;
run.EndsWithRiser = true;
}
}
}
Copy
VB.NET
Private Sub AddStartandEndRisers(stairs As Stairs)
Dim runIds As ICollection(Of ElementId) = stairs.GetStairsRuns()
For Each runId As ElementId In runIds
Dim run As StairsRun = TryCast(stairs.Document.GetElement(runId), StairsRun)
If run IsNot Nothing Then
run.BeginsWithRiser = True
run.EndsWithRiser = True
End If
Next
End Sub