An enumerated type listing all of the internal parameter data storage types that Autodesk Revit supports.
Namespace:
Autodesk.Revit.DB
Assembly:
RevitAPI
(in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
None | None represents an invalid storage type. This value should not be used. |
Integer | The internal data is stored in the form of a signed 32 bit integer. |
Double | The data will be stored internally in the form of an 8 byte floating point number. |
String | The internal data will be stored in the form of a string of characters. |
ElementId | The data type represents an element and is stored as the id of the element. |